From ca9627e70852f6b2e835660df870fe3ab405882d Mon Sep 17 00:00:00 2001
From: "Suren A. Chilingaryan" <csa@suren.me>
Date: Sun, 1 Sep 2019 00:00:32 +0200
Subject: Initial import

---
 app-arch/p7zip/p7zip-4.44-r2.ebuild | 87 +++++++++++++++++++++++++++++++++++++
 1 file changed, 87 insertions(+)
 create mode 100644 app-arch/p7zip/p7zip-4.44-r2.ebuild

(limited to 'app-arch/p7zip/p7zip-4.44-r2.ebuild')

diff --git a/app-arch/p7zip/p7zip-4.44-r2.ebuild b/app-arch/p7zip/p7zip-4.44-r2.ebuild
new file mode 100644
index 0000000..2604381
--- /dev/null
+++ b/app-arch/p7zip/p7zip-4.44-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.44.ebuild,v 1.7 2007/03/25 18:14:50 armin76 Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Port of 7-Zip archiver for Unix"
+HOMEPAGE="http://p7zip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~ppc ~ppc-macos ~ppc64 sparc x86 ~x86-fbsd"
+IUSE="static doc"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+	sed -i \
+		-e "/^CXX=/s:g++:$(tc-getCXX):" \
+		-e "/^CC=/s:gcc:$(tc-getCC):" \
+		-e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
+		-e 's:-s ::' \
+		makefile* || die "changing makefiles"
+
+	if use amd64; then
+		ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
+		cp -f makefile.linux_amd64 makefile.machine
+	elif use ppc-macos; then
+		# Mac OS X needs this special makefile, because it has a non-GNU linker
+		cp -f makefile.macosx makefile.machine
+	elif use x86-fbsd; then
+		# FreeBSD needs this special makefile, because it hasn't -ldl
+		sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
+	fi
+	use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
+
+#SDS	
+	EPATCH_OPTS="-p1" epatch ${FILESDIR}/p7zip_4.44-libun7zip.patch || die
+	epatch ${FILESDIR}/p7zip-ds-rcc.patch || die
+#EDS	
+}
+
+src_compile() {
+	emake all3 || die "compilation error"
+#SDS
+	emake -C CPP/7zip/Bundles/Un7Zip || die
+#EDS
+}
+
+src_install() {
+	# this wrappers can not be symlinks, p7zip should be called with full path
+	make_wrapper 7zr "/usr/lib/${PN}/7zr"
+	make_wrapper 7za "/usr/lib/${PN}/7za"
+	make_wrapper 7z "/usr/lib/${PN}/7z"
+
+	dobin ${FILESDIR}/p7zip
+
+	# gzip introduced in 4.42, so beware :) 
+	# mv needed just as rename, because dobin installs using old name
+	mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg
+	dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg
+
+	exeinto /usr/$(get_libdir)/${PN}
+	doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
+	exeinto /usr/$(get_libdir)/${PN}/Codecs
+	doexe bin/Codecs/* || die "doexe Codecs"
+	exeinto /usr/$(get_libdir)/${PN}/Formats
+	doexe bin/Formats/* || die "doexe Formats"
+
+	doman man1/7z.1 man1/7za.1 man1/7zr.1
+	dodoc ChangeLog README TODO
+
+	if use doc ; then
+		dodoc DOCS/*.txt
+		dohtml -r DOCS/MANUAL/*
+	fi
+
+#SDS
+        mkdir -p ${D}/usr/lib/
+	mkdir -p ${D}/usr/include/
+	install -s -D -m 755 CPP/7zip/Bundles/Un7Zip/libun7zip.so ${D}/usr/lib/libun7zip.so || die
+	install -D -m 644 CPP/7zip/Bundles/Un7Zip/u7zip.h ${D}/usr/include/u7zip.h || die
+#EDS
+}
-- 
cgit v1.2.3