summaryrefslogtreecommitdiffstats
path: root/build/linux/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'build/linux/configure.ac')
-rw-r--r--build/linux/configure.ac26
1 files changed, 0 insertions, 26 deletions
diff --git a/build/linux/configure.ac b/build/linux/configure.ac
index cbf6016..24f0124 100644
--- a/build/linux/configure.ac
+++ b/build/linux/configure.ac
@@ -48,32 +48,6 @@ dnl Use iostream to check if the C++ compiler works
AC_CHECK_HEADER(iostream, , AC_MSG_ERROR([No working c++ compiler found]))
-# clock_gettime
-
-AC_MSG_CHECKING([for clock_gettime])
-AC_TRY_LINK([
-#include <ctime>
-],[
-struct timespec t; clock_gettime(CLOCK_REALTIME, &t);
-],astra_clock_gettime_ok=yes,astra_clock_gettime_ok=no)
-AC_MSG_RESULT($astra_clock_gettime_ok)
-if test x$astra_clock_gettime_ok = xno; then
- AC_MSG_CHECKING([for clock_gettime in librt])
- LIBS="$LIBS -lrt"
- AC_TRY_LINK([
- #include <ctime>
- ],[
- struct timespec t; clock_gettime(CLOCK_REALTIME, &t);
- ],astra_clock_gettime_ok=yes,astra_clock_gettime_ok=no)
- AC_MSG_RESULT($astra_clock_gettime_ok)
- if test x$astra_clock_gettime_ok = xno; then
- AC_MSG_ERROR([No clock_gettime found])
- else
- SAVED_LIBS="$SAVED_LIBS -lrt"
- fi
-fi
-
-
# boost-unit-test-framework
AC_MSG_CHECKING([for boost-unit-test-framework])