summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df596e7..d9a0f5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,7 +30,10 @@ set (CIL_VERSION '${CIL_VERSION_MAJOR}.${CIL_VERSION_MINOR}.${CIL_VERSION_PATCH}
# set the Python variables for the Conda environment
#include(${CMAKE_SOURCE_DIR}/CMake/FindAnacondaEnvironment.cmake)
+option (BUILD_MATLAB_WRAPPERS "Build Matlab Wrappers" OFF)
+option (BUILD_PYTHON_WRAPPERS "Build Python Wrappers" OFF)
+option (CONDA_BUILD "Conda Build" OFF)
+option (BUILD_CUDA "Build the CUDA modules" ON)
+
add_subdirectory(Core)
-if (BUILD_WRAPPERS)
- add_subdirectory(Wrappers)
-endif() \ No newline at end of file
+add_subdirectory(Wrappers)