summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2015-06-16 16:32:45 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2015-06-16 16:32:45 +0200
commit03a45db7f3905ba834e4a0690b70936bd37b2633 (patch)
tree38ed54b3771dd3c205e3658eacf722467d326b01 /CMakeLists.txt
downloaduca-ufo-03a45db7f3905ba834e4a0690b70936bd37b2633.tar.gz
uca-ufo-03a45db7f3905ba834e4a0690b70936bd37b2633.tar.bz2
uca-ufo-03a45db7f3905ba834e4a0690b70936bd37b2633.tar.xz
uca-ufo-03a45db7f3905ba834e4a0690b70936bd37b2633.zip
Initial commit
For the past plugin history refer to the libuca repository.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..25a4542
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,34 @@
+# --- Common ------------------------------------------------------------------
+
+cmake_minimum_required(VERSION 2.6)
+project(ucapco C)
+
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+
+find_package(PkgConfig)
+include(PkgConfigVars)
+
+add_definitions("-std=c99 -Wall")
+
+pkg_check_modules(UCA libuca>=2.0.0 REQUIRED)
+pkg_check_modules(GIO2 gio-2.0>=2.24 REQUIRED)
+pkg_check_variable(libuca plugindir)
+
+
+# --- Plugin specific ---------------------------------------------------------
+
+find_package(IPE REQUIRED)
+
+include_directories(
+ ${IPE_INCLUDE_DIRS}
+ ${GIO2_INCLUDE_DIRS})
+
+add_library(ucaufo SHARED uca-ufo-camera.c)
+
+target_link_libraries(ucaufo
+ ${UCA_LIBRARIES}
+ ${GIO2_LIBRARIES}
+ ${IPE_LIBRARIES})
+
+install(TARGETS ucaufo
+ LIBRARY DESTINATION ${LIBUCA_PLUGINDIR})