From a52b301fcc0f4f91fadfd92254629502107deda9 Mon Sep 17 00:00:00 2001
From: Matthias Vogelgesang <matthias.vogelgesang@kit.edu>
Date: Mon, 18 Jan 2016 16:01:41 +0100
Subject: Implement sensor height as compile-time constant

---
 CMakeLists.txt | 5 +++++
 1 file changed, 5 insertions(+)

(limited to 'CMakeLists.txt')

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 20539a6..6ee5d82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,12 @@ if (NOT DEFINED CMOSIS_SENSOR_WIDTH)
     set(CMOSIS_SENSOR_WIDTH "2048")
 endif ()
 
+if (NOT DEFINED CMOSIS_SENSOR_HEIGHT)
+    set(CMOSIS_SENSOR_HEIGHT "1088")
+endif ()
+
 set(CMOSIS_SENSOR_WIDTH ${CMOSIS_SENSOR_WIDTH} CACHE STRING "Width of the sensor")
+set(CMOSIS_SENSOR_HEIGHT ${CMOSIS_SENSOR_HEIGHT} CACHE STRING "Height of the sensor")
 
 configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
                ${CMAKE_CURRENT_BINARY_DIR}/config.h)
-- 
cgit v1.2.3