From b9ce6027dde8b3c6fd002d38e3cee07e7711d73c Mon Sep 17 00:00:00 2001
From: Matthias Vogelgesang <matthias.vogelgesang@kit.edu>
Date: Thu, 4 Jul 2013 16:46:30 +0200
Subject: Move timer functions into timer.{c,h}

---
 test/CMakeLists.txt | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

(limited to 'test/CMakeLists.txt')

diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index aea7b7d..7539c19 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,9 +1,20 @@
 # --- Build test executable -------------------------------------------------
+include(CheckIncludeFile)
+
+check_include_file("sys/time.h" HAVE_SYS_TIME_H)
+
+if (NOT HAVE_SYS_TIME_H)
+    message(FATAL_ERROR "sys/time.h not found")
+endif()
+
 include_directories(
     ${CMAKE_SOURCE_DIR}/src 
 )
 
-add_executable(ipedec ipedec.c)
+add_executable(ipedec
+               ipedec.c
+               timer.c)
+
 target_link_libraries(ipedec ufodecode)
 
 install(TARGETS ipedec DESTINATION ${BIN_INSTALL_DIR})
-- 
cgit v1.2.3