summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2007-06-27 09:17:03 +0000
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2007-06-27 09:17:03 +0000
commitb68103e7018957e6fd25610da1d65deedd825497 (patch)
treef4815d103363a343ab0f7d5a21a6c47c5c318e87 /configure.in
parent1b2aa527c43c89acc48fb146b2d61ed15eef5b61 (diff)
downloadlibrcd-b68103e7018957e6fd25610da1d65deedd825497.tar.gz
librcd-b68103e7018957e6fd25610da1d65deedd825497.tar.bz2
librcd-b68103e7018957e6fd25610da1d65deedd825497.tar.xz
librcd-b68103e7018957e6fd25610da1d65deedd825497.zip
ISO-8859-1 support
- Try to detect genuine ISO-8859-1 encoding
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ad8cd6..15d197f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(src/librcd.c)
+AC_CONFIG_HEADERS(config.h)
PACKAGE=librcd
LIBRCD_VERSION_MAJOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 1 | sed -e s/^$/0/`
@@ -17,6 +18,14 @@ AC_SUBST(LIBRCD_VERSION_INFO)
AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+AC_ARG_ENABLE( latin,
+ [ --disable-latin disable detection of ISO-8859-1],,
+ disable_latin="yes")
+
+if test "x$disable_latin" == "xyes"; then
+ AC_DEFINE(DETECT_LATIN,1,[Defines if ISO-8859-1 detection is enabled])
+fi
+
AC_PROG_CC
AC_PROG_INSTALL
AM_PROG_LIBTOOL