summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ad8cd6..15d197f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(src/librcd.c)
+AC_CONFIG_HEADERS(config.h)
PACKAGE=librcd
LIBRCD_VERSION_MAJOR=`cat VERSION | sed -e s/CVS// | cut -d . -f 1 | sed -e s/^$/0/`
@@ -17,6 +18,14 @@ AC_SUBST(LIBRCD_VERSION_INFO)
AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+AC_ARG_ENABLE( latin,
+ [ --disable-latin disable detection of ISO-8859-1],,
+ disable_latin="yes")
+
+if test "x$disable_latin" == "xyes"; then
+ AC_DEFINE(DETECT_LATIN,1,[Defines if ISO-8859-1 detection is enabled])
+fi
+
AC_PROG_CC
AC_PROG_INSTALL
AM_PROG_LIBTOOL